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INTRODUCTION 
 
 
  
   Thank you for downloading our theme. We are thrilled to have you use it and to empower 
you and your ministry to do what you are called to do. We assure you will not be disappointed. 
We do our best to produce a top-notch theme with great functionality, premium designs, and 
clear code.  
 
   Compass is a responsive and clean Rock RMS theme, shipped with five customized 
shortcodes, one content channel type, and lots of useful lava files and layouts as needed (as 
you will see below). 
 
   9 Embers was founded with the desire to bring our experience and expertise in Rock to help 
churches, regardless of their technical capabilities. If you need additional hands, we will meet 
you where you are and implement a fully managed Rock environment that is tailored to your 
ministry's exact needs. Simply reach out to us at https://9embers.com and we will respond as 
soon as possible. 
 
   
 
GETTING STARTED 
 
 
    
   Once you install the plugin from the Rock shop, you will want to set your colors and compile 
the theme. Simply navigate to the theme under “Admin Tools > CMS Configuration > Themes” 
and click on the “Compass” theme. Once there, change the Compass Primary and the Compass 
Secondary colors to be the hex colors of your choice (see screenshot on next page). 
 
   For future reference: If you need to change the width of your site navigation menu from when 
it converts from a desktop view into a “hamburger” icon view (usually for mobile and tablet 
screens), then you can easily change this by changing the “Compass Nav to Mobile” width – 
which is at the default width of 992px. In other words, the desktop navigation menu will change 
to the hamburger navigation at 991px; so, change that if you need it to be longer or shorter.  

 



Last updated: 02/29/24  9 Embers 
 

3 

If you want to change the default colors of the page title and header, you can do so at #3 and 
#4 in the screenshot below. 
 
Once you have your colors changed, click “Save”, and then Rock will compile the theme with 
your new colors. 
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USING COMPASS WITH A SITE  
 
  
 

Great News! As of v4.2.1 or greater, you will not need to re-create any of the 
pages or configure any of the features below. We have written a migration that 
will do all the work upon a fresh installation of the plugin. Once installed, you can 
find these pages under: 
CMS Configuration > Pages > Home (with Compass Site already assigned to it). 

 
If you have previously installed Compass, or if you would like to make additional edits to any of 
the Compass features, then you can proceed below. The migration will not overwrite any 
existing Compass features if already installed. 
 
 
 
     
Whether you are creating a brand-new Rock site with this theme, or using an existing site, make 
sure to change the theme selection to “Compass” (as shown in the screenshot below). 
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   If you are creating a brand-new site, we recommend following the article of “Creating a New 
Site” under the “Designing and Building Websites Using Rock” manual at the rock community 
website, and choose the “Compass” theme selection along the way.  
 
   Once saved, you have a site and a theme ready to roll, but we need to set up all the 
corresponding pages along with their blocks, shortcodes, and content channels.  
 
 
 
COPY EXTERNAL HOMEPAGE AND CHILD PAGES  
(Skip this if you are using an existing site, or if you installed Compass at version 2.4.1 or greater) 
 
  
    
   We need to copy the “External Homepage” and child pages, and then point them to the new 
site. This means once we copy all the pages, we will need to configure each page individually. 
Fortunately, for almost all the pages, there are only two things to change: the site, and the 
layout. 
 

1. Navigate to “Admin Tools > CMS Configuration > Pages”. 
2. Select “External Homepage”, and then click on the “Copy Page” icon within the bottom 

right corner of the top panel (see screen shot in the next page). 
 

 
 

3. Once clicked, a modal will pop up – make sure the “Include Child Pages” checkbox is 
checked before you click “Copy”. 
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CONFIGURE ALL COPIED PAGES 
 
 
 
   For each of the pages you want to include in your Compass themed site, you need to do at 
least two things within the page settings:  
 

1) Change the “Site” to be the site where the Compass theme is selected.  
2) Change the layout to their corresponding layouts. 
 

Note: 
This theme comes with default layouts that should take care of most existing themes using 
Stark or Flatly, and it comes with one additional layout for a fluid width. Therefore, if you want 
to keep the existing “FullWidth” layout, then simply select “Full Width Container” as a 
replacement when using Compass. If you would like to try a fluid width instead (better for 
photo sliders, or any design that involve 100% width of the screen), then change it to be “Full 
Width Fluid”. 

 

 
In the example above, for the “New Here?” page, you would need to change the site 
(#1), and since this page was originally the “FullWidth” layout from Stark, you would 
want to change the layout to be the “Full Width Container” layout (#2). 
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   Do this for each page you have copied for your site. There are approximately 70 pages to go 
through and this includes all the support pages. Once you are done with that, we will circle back 
and add blocks to the home page to allow you to experience all the additional features this 
theme comes with. 
 
 
 
 
 
HOME PAGE 
 

  
 

   To achieve the look of the Compass Home page, we are now going to add all its related blocks 
(which also includes some site-wide blocks) and create one content channel to manage the 
photo gallery. Before we do that, make sure you are on the “External Homepage – Copy” page. 
Once you are there, click “Edit”, and follow the settings below: 
 

Under “Basic Settings”: 
• Change the internal page name to a title of your choice. Usually we would put 

“(insert-your-church-name-here) Home” if it isn’t taken. 
• Change the Site dropdown to the site you managed from earlier. 
• Change the Layout dropdown to “Full Width Fluid” 
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Under “Display Settings”: 

• Uncheck “Show Title on page” 
• Uncheck “Show Breadcrumbs on Page” 
 

    
    Then click “Save”, and you are done with the home page settings, but we need to add the 
home page blocks next, and we are going to start with the “NavLogo” Zone. You will find this 
selection if you choose the dropdown on the right-hand side of the second panel (see 
screenshot on next page).  
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   Once you have the “NavLogo” Zone selected, follow the list below to add a “[Site] Nav Logo” 
block. This block will be responsible for displaying your church logo from your site settings. 
 

o   Click the + (add) “Add Block to Zone” button 
•  The name should be “[Site] Nav Logo” 
• Make sure the Type of the block is “HTML Content” 
• For “Add To”, make sure to select “Site”, and then click “Save” 
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   Now click on the edit icon for the “[Site] Nav Logo” block, and make sure you are in the “Code 
Editor” view, and paste the code below: 
 

 
 
   Change the HomeURL lava variable as needed to the home page of this site and click “Save”.  
 

 
Congrats! You finished the first sitewide block on your Compass Themed site. 

 
   Next, we will add a block that is responsible for the website navigation by using the default 
page-menu block. Change your zone to the “Nav” Zone and add another site block (as shown 
previously). Name this block “[Site] Page Menu”, and make sure it is a “Page Menu” block type. 
Once added, click on block properties (the gear icon) – make sure the “Root Page” is set to the 
homepage of the new site, and then replace the template code with the code in the following 
URL:  
 

https://compass.9embers.com/documentation/pagemenu 
 
 

  

{%- assign HomeURL = "/home" -%} 
{%- include '~~/Assets/Lava/Site/NavLogo.lava' -%} 



Last updated: 02/29/24  9 Embers 
 

11 

Change the lava URL variables as needed, and then click “Save” when finished. To learn 
more about the different options and settings for dropdowns, you can jump to page #38 of this 
documentation. If you do not want dropdowns, then simply change the “Number of Levels” 
from “3” to “1”. 
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“Feature” Zone - Select the “Feature” zone and delete the Content Channel View block if it exists. 
This is a banner slider that usually comes with Rock initially, but we will not be using it. 
    
 
“Main” Zone - Navigate to the “Main” Zone, and add four HTML content page blocks, and name 
them the following: “Hero”, “Intro”, “Gallery”, and “CTA” (see screenshot below). 

 
 
At this point, we are going to add content to all the Main Zone HTML blocks and get it to match 
the demo site of the Compass theme. In case you need it for reference, you can find the demo 
site at this link: https://compass.9embers.com 
 
If you do not want any of this content, feel free to skip ahead as needed. 
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HOME PAGE – Hero Video 
 
 

    
   For the “Hero (HTML Content)” block, edit it (click on the pencil icon), then copy & paste the 
code in the following URL to the code editor for your “Hero (HTML Content)” block:  
 

https://compass.9embers.com/documentation/hero 
 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Home/home_hero.lava” 

 
   Once saved, refresh your page and you will see a sample hero video playing below the site 
navigation. For additional information about this shortcode, please reference the 
documentation under “Admin Tools > Lava Shortcodes > [9 Embers] Jarallax”.  
 
   As you may notice, there is another shortcode used as well, and it is the “wow” shortcode; 
this is what allows the html elements inside of jarallax to be animated. To see more about that, 
please reference the documentation for it under “Admin Tools > Lava Shortcodes > [9 Embers] 
Wow Animations”. 
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HOME PAGE – Intro 

 
 

    
For the “Intro (HTML Content)” block, we must warn you that it is a heavy chunk of HTML with 
lots of CSS classes, but in the future, we plan to convert this into a shortcode, and it will be 
easier to change. For now, if you want it, go to this URL:  
 

https://compass.9embers.com/documentation/intro 
 

Then copy the code and paste it in your code editor for the “Intro (HTML Content)” block. 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Home/home_intro.lava” 
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HOME PAGE – Gallery  
 
 

    
   For our gallery block on this home page, we are going to take a pause here and create a 
content channel that is needed for this. 
 

Navigate to “Admin Tools > CMS Configuration > Content Channels” 
1. Click the + (add) button at the bottom of the grid. 
2. Set the name of your channel to be “Home Gallery” 
3. Set the type of the channel to “Photo Gallery” 
4. Set the Icon CSS Class to be “fa fa-images” 
5. Make sure the “Items Manually Ordered” is checked. 
6. Click “Save”. 
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Now we have a channel, but we need to add content into the content channel! Navigate to 

this new content channel (“Tools > Content > Home Gallery”), and then add at least six new 
content records. For sample references, you can add the following photos/names: 

 
• Title: Water 

o Content: Waterfall in Nature 
o Image: You can upload your own photo, or grab the sample photo from 

“/Compass/Assets/img/theme/sample_images/gallery/466.jpg” 
• Title: Freedom 

o Content: Sunshine rays with Freedom 
o Image: You can upload your own photo, or grab the sample photo from 

“/Compass/Assets/img/theme/sample_images/gallery/646.jpg” 
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• Title: Hilltop 
o Content: On the hilltop of Ireland 
o Image: You can upload your own photo, or grab the sample photo from 

“/Compass/Assets/img/theme/sample_images/gallery/510.jpg” 
• Title: Railroad 

o Content: Railroad track 
o Image: You can upload your own photo, or grab the sample photo from 

“/Compass/Assets/img/theme/sample_images/gallery/204.jpg” 
• Title: Rustic Bike 

o Content: Vintage rustic bike and building 
o Image: You can upload your own photo, or grab the sample photo from 

“/Compass/Assets/img/theme/sample_images/gallery/76.jpg” 
• Title: Town 

o Content: Small town in Galway 
o Image: You can upload your own photo, or grab the sample photo from 

“/Compass/Assets/img/theme/sample_images/gallery/405.jpg” 
 
 
   Once your content channel is set, you will need to make note of your Content Channel ID. See 
the following screenshot:  
 

 
   Lastly, we navigate back to the home page. Find the “Gallery (HTML Content)” block, edit it 
(click on the pencil icon), then copy and paste the code below into the code editor (but don’t 
click “Save” yet!): 
 

 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Home/home_gallery.lava” 

{[ lightgallerycc id:'9' ]}{[ endlightgallerycc ]} 
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   Next, change the number “9” to the Content Channel Id you made note of, and then click 
“Save”; by changing this Id, you will be able to pull photos from your new content channel. 
Lastly, edit the block properties (the gear icon) and make sure the “RockEntity” command is 
enabled.  

 
Once you save all that, refresh your page, you will see a photo gallery! 
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HOME PAGE – CTA (Call to Action) 
 
 

 
   For the “CTA (HTML Content)” block, this is another chunk of HTML with lots of CSS classes, 
and we plan to make this easier, but for now (if you want it), go to this URL: 
 

https://compass.9embers.com/documentation/cta 
 

Then copy the code and paste it in your code editor for the “CTA (HTML Content)” block. 
 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Home/home_cta.lava” 
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HOME PAGE – Footer 
 
 

 
 
    “Footer” Zone - Navigate to the “Footer” Zone and add one last HTML block as a part of the 
site. Name this “[Site] Footer”, and then copy the code from the following URL and paste it into 
your “[Site] Footer (HTML Content)” block. 
 

https://compass.9embers.com/documentation/footer 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Site/SiteFooter.lava” 

    
Once saved, you may or may not notice that the Compass logo does not show. This is because 
this logo is directly managed from the site settings. Once you upload your own Site Icon, then 
you will see your changes in the footer. 
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HOME PAGE – Church Online Service Countdown (Optional) 
 
  

 
   At this point, you should have a working home page! The only thing left on it is the Church 
Online Service countdown timer (this is optional). To configure it, do the following: 
 
 Navigate to “Admin Tools > General Settings > Define Types > Lava Webhook”. 

1. Click the + (add) button. 
2. Set the value to “/livestreaming/services” 
3. Set the description to be “This webhook allows a countdown timer to be 

displayed on the home page, and then a "live streaming" button when active.” 
4. Make sure “Active” is checked. 
5. Leave “Method” blank. 
6. Copy the code from the following URL, and paste it into the Template:  

 
https://compass.9embers.com/documentation/webhook 

 
For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Webhooks/StreamingServices.lava” 

 
7. With the code above, change the “domain” lava variable to be the church’s 

church online platform URL. 
8. Make sure “Cache” and “WebRequest” lava commands are checked. 
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9. Click “Save”. 

 
   Now that the webhook is set, go back to your home page, edit the “Hero (HTML Content)” 
block and change one of the jarallax shortcode options from “churchonlinecountdown:'false'” 
to churchonlinecountdown:'true'” (see screenshot on the next page). Click “Save” and then 
you should have a working church online countdown!   
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   Note: when the timer is up, it will display “LIVE STREAMING NOW” with a hyperlink directly to 
your church online platform (as shown below). 
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NEW HERE PAGE – HERO SWIPER 
 
 

    
   One last additional feature with the Compass Theme is the heroswiper shortcode. For 
information about this, please reference the documentation under “Admin Tools > Lava 
Shortcodes > [9 Embers] Hero Swiper”. For demonstration purposes, we added this into the 
default “New Here?” page that Rock comes with, but you can add to this to any Compass theme 
page you wish.  
 

1. Once you are on a page of your choice, go into your page settings, and change 
the Layout to “Full Width Fluid”. This will allow the swiper shortcode to be at the 
full width of your screen. 

2. Add a new “HTML Block” into the “Feature” Zone and call it “Hero Swiper”.  
3. Copy the code from the following URL, and paste it into the code editor of your 

“Hero Swiper (HTML Content)” block:  
 

https://compass.9embers.com/documentation/swiper 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Visit/heroSwiper.lava” 

 
Once you click “Save”, you should then have a working hero slider! 
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TEAM PAGE (Part #1 – Team Members) 
*Available in version 1.4  

 
   In version 1.4 of the Compass theme - there are two new features! One of them is the ability 
to display members from a group onto a page in a card style layout (team), and the other is 
ability to display custom accordions (see next section). 
 
   Through group member attributes, you will be able to set a picture, name, role, a short 
paragraph, priority, and as many rows (attribute matrix) as you’d like for the accordions at the 
bottom of the cards.  
 
   Due to the number of possibilities, it will take some time to set up the groups and attributes, 
but we promise you it will be so worth it! When ready, we are going to start with creating an 
Attribute Matrix to allow for adding FAQs or facts for each group member.  
 
   Navigate to “Admin Tools > General Settings > Attribute Matrix Templates” and click the + 
(add) button. 
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1) Set the name to be “Additional Information” 
2) Set the description to be “This matrix is to allow additional information to be 

displayed in an accordion style layout for "Teams".” 
3) Make sure “Active” is checked. 

 
4) Click the + (add) button to add new Item Attribute of “Title”. 

(a) Set the Name to be “Title” 
(b) Make sure the Key is set to “Title” 
(c) Set the field type to be “Text”. 
(d) Click “Save”. 

 
5) Click the + (add) button again, we will add another Item Attribute of “Answer” 

(a) Set the Name to be “Answer” 
(b) Make sure the Key is set to “Answer” 
(c) Set the field type to be “Text”. 
(d) Click “Save”. 

 
6) Click on “Advance” to open the settings and delete all of the code under 

“Formatted Lava”. 
7) Copy the code from the following URL, and paste it into “Formatted Lava”:  

 
https://compass.9embers.com/documentation/teams-attribute-matrix 

 
For developer references, you can find this code snippet under:  
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“/Themes/Compass/Assets/Lava/Pages/Team/additionalInfo-attributematrix.lava” 
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Once you click “Save”, we are ready to move on!  
 

For this next step, you have a choice. You can either modify an existing group type and add the 
attributes below or add a new group type and keep it fresh. For demonstration and ease of use, 
we are creating a new group type. 
 
Navigate to “Admin Tools > General Settings > Group Types” and click the + (add) button.  
 

1) Set the name to be “Compass Teams” 
2) Set the description to be “This group type is to manage available members to be 

displayed on the public website using the Compass Theme.” 
3) Open “General”, and make sure the “Allow Any Child Group Type” option is 

checked. 
4) Scroll down to “Member Attributes” and click on it to open. 

 
5) Click the + (add) button to add new member attribute of “Person Image”. 

a) Set the Name to be “Person Image” 
b) Set the Description to be “An image to be displayed for the person. The 

default size 500px by 500px. If larger or smaller, it will scale and be cropped.” 
c) Make sure the Key is set to “PersonImage” 
d) Set the Field Type to be “Image” 
e) Set the File Type to be “Media File” 
f) Click “Save” 

 
6) Click the + (add) button to add new member attribute of “Person Subtitle”. 

a) Set the Name to be “Person Subtitle” 
b) Set the Description to be “If you would like to display a role or a simple string 

under the name, enter it here.” 
c) Make sure the Key is set to “PersonSubtitle” 
d) Set the Field Type to be “Text”. 
e) Click “Save” 

 
7) Click the + (add) button to add new member attribute of “Person Priority”. 

a) Set the Name to be “Person Priority” 
b) Set the Description to be “This is to set the order of the person wherever 

displayed. If order is not an issue, you can leave this empty.” 
c) Make sure the Key is set to “PersonPriority” 
d) Set the Field Type to be a “Integer” 
e) Make sure “Show in Grid” is checked 
f) Click “Save” 

 
8) Click the + (add) button to add new member attribute of “Person Intro”. 

a) Set the Name to be “Person Intro” 
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b) Set the Description to be “If you would like some copy displayed under the 
person's role/name. Enter it here.” 

c) Make sure the Key is set to “Intro” 
d) Set the Field Type to be a “HTML” (Light) 
e) Click “Save” 

 
9) Lastly, click the + (add) button to add new member attribute of “Additional 

Information”. 
a) Set the Name to be “Additional Information” 
b) Set the Description to be “This attribute is to show additional information 

within an accordion style layout (below the intro). You can add as many as 
needed.” 

c) Make sure the Key is set to “AdditionalInfo” 
d) Set the Field Type to be a “Matrix” 

(1) Once set, choose the Attribute Matrix Template of “Additional 
Information” 

e) Click “Save” 
 

Once you have all your attributes set, it should look like the following screenshot. 

 
10) Finally, click “Save” to complete the new Group Type. 
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Next, we need to make sure the View security settings for the new group type is allowed for all 
users. This will ensure your ability to display your members on the website. If you do not do 
this, then your teams page will be empty. By the way, you can either set this security on the 
group type or the group that uses this group type. For demonstration, we are setting it on the 
new group type; this way all groups using this type, will inherit the view permissions 
automatically. 
 
To set the security, find your new group type (“Compass Teams”) and click on the lock symbol 
directly to the right of it. It should look like the following: 

 
Then within the pop-up modal, click “Add Role” and make sure “[All Users]” is selected, and 
leave the “View” checkbox as checked (leave the others unchecked). Once saved, your View 
permissions should look like the following:   
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When ready, click “Done” (bottom right corner), and the next step will be to create a group 
using this group type. To do this, navigate to “People > Group Viewer”. 

 
Before we create a group though, we need to make sure we can see all groups of this type. 
Therefore, we will need to edit the “GroupViewLeft” block. To edit it, you need to click on the 
“Block Configuration” icon on the bottom nav bar: 
 

 
Then click on the “Gear” icon for the “GroupViewLeft” block: 
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Once opened, make sure “Compass Teams” is selected, and the “Root Group” is set to empty 
(You can change this later if needed). See the following screenshot to see what needs to be 
changed, and when ready – scroll down – and click “Save”. 

 
At this point, we can finally add a group with members! From the same page, click on “(+) Add 
Group” and choose “Add Top-Level”. Once the new page loads, go ahead and set the following: 
 

1) Set the Name. For demonstration, we typed out “Public Team”, but you are free to 
name your group to what sounds right to you, such as “Pastors”, “Staff”, or 
“Community Pastors” to name a few others.  

2) Set the Description. For demonstration, we typed out “A team to be displayed on the 
“Teams” page of the website.”  

3) Select “Compass Teams” as your Group Type.  
4) Click “Save” 
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Now that we have a group. You will need to add individual members to the group. You can do 
this by clicking on the (+) button on the bottom right corner of your group. To match what we 
have on our Compass demo site, make sure you fill out the Person, Person Image, Person 
Subtitle, and a few “Additional Information” to be displayed on the bottom of the cards. Note: 
The only thing required is a Person. You can leave all the other fields empty, if you’d like, and 
the cards will display only what is available.  
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Once you have your individual members created. It should look like the following: 
 

 
 
At this point, we are ready to create a web page and use this group! As we continue though, 
make sure you make a note of your group Id for the next step. See the following screenshot. 
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Next, navigate to the home page of your Compass themed site and create a new child page 
called “Team” with the layout of “Full Width Container”. Then go to the “Main” Zone and add 
two HTML content page blocks. Name them the following: “Team”, and “FAQs” (see screenshot 
below).  
 

 
 
 
Click “Done” to close the zone. Then edit the block for “Team (HTML Content)”, and copy & 
paste the code from the following URL to your code editor:  
 

https://compass.9embers.com/documentation/team 
 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Team/team.lava” 

 
   Next, change the number “4172” to the Group Id you made note of, and then click “Save”; by 
changing this Id, you will be able to pull in your members from your new group. Lastly, edit the 
block properties (the gear icon) and make sure the “RockEntity” command is enabled.  
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Once you save all that, refresh your page, you will see a card layout of your team members! 
Additionally, if you have more than 4 members, the layout is centered by default. If you want 
this to be left-aligned instead, you can change the lava variable “centerItems” to be “false”. 
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TEAM PAGE (Part #2 – Custom Accordions) 
*Available in version 1.4  

 

 
As bonus for the team page (and the site), we have custom accordions! If you have been 
following along from the previous part of this team page, then you should have an HTML 
Content block named “FAQs”. Edit that block, and copy & paste the code from the following 
URL into your code editor:  
 

https://compass.9embers.com/documentation/team-faq 
 
 

For developer references, you can find this code snippet under: “/Themes/Compass/Assets/Lava/Pages/Team/faqs.lava” 
 

 
Once you click “Save”, refresh your page, and will have a working FAQ section. 
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MULTI-DROPDOWN SITE NAVIGATION 
*Available in version 2.0  

 
 
In version 2.0, the Compass theme now has a way for you to manage multi-dropdowns for your 
site menu! If you updated your theme to this version, you may notice dropdowns have already 
applied to your menu; this is expected, and there is an easy way turn off dropdowns if needed.  
 
If you installed this theme previously, then we will need to update the page menu block. From 
your home page, edit the “Page Menu” block by clicking on the block properties (the gear icon) 
– and replace the template code with the code in the following URL:  
 

https://compass.9embers.com/documentation/pagemenu 
 
 

* If you need to turn off the dropdowns, then from within the block settings, you can change 
the value for “Number of Levels” from 3 to 1. This will revert the menu back to a single level 
menu.  
 
Once you update the code in the template, you will notice two additional variables compared 
to before; they are “Include Primary Child Link Mobile and Tablet” and “Include Primary Child 
Link Desktop” (with no spaces). These Boolean variables will help you decide whether a primary 
child link will be included underneath the dropdowns for mobile and tablet and/or desktop.  

 
Before we explain, make sure to update the previous variables for your Home URL, Login URL, 
and My Account URL. 
 
To help understand what the new variables do, we will walk through on how it works for 
mobile, and then you can apply the same concept for desktop as needed. 
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In the first screenshot below, this is what your site menu would normally look like on a mobile 
screen. If you were to touch one of the dropdowns, then it will open the corresponding child 
items. In this example, the “Give” dropdown was selected. If you notice, you see all of the child 
items under “Give”, but not the Give page itself. This is because on mobile screen, you can only 
touch to toggle the accordions.  
 

 
Therefore, as a work around to access these primary links, we have two options:  
 

1) The first option is to make a copy of the primary page (Give in this case) and put it as 
a child page under it. This works, but you will have to do this for every dropdown 
item as needed and update the page routes. 
 

2) The second option is set the Boolean value of “Include Primary Child Link Mobile and 
Tablet” to true. 

 

 
When set to true, this will add a primary link for every dropdown as an option and be visible 
only on Mobile and Tablet. See screenshot on the next page for how this change is made. 
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In the same concept, if you want it visible on desktop as well, then you can set the next 
variable, “Include Primary Child Link Desktop”, to be true. 

 
In the following screenshot, you can see how this change is made for desktop.  
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At this point, you are set for dropdowns! Next, we will show you how to re-organize your 
dropdowns and only show selected pages.  
 
To re-organize your menu, navigate to your home page, and click on the “Child Pages” button; 
see below.  

 
Then to re-organize, simply drag-and-drop the items in the order you want them to be in. In this 
example, we moved “Connect” to be the first item of the primary menu. 
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Once saved (by clicking on “Done”), you will see your menu re-organized in the way you 
ordered it. As shown below, “Connect” is now the first item on both mobile and desktop. 
 
Desktop: 

 
Mobile: 

 
For the child items, you will follow the same pattern. Simply go to one of your pages, such as 
“Connect”, and click on the “Child Pages” button; see below. 



Last updated: 02/29/24  9 Embers 
 

44 

Then, just like before, simply drag-and-drop the child items in the order you want them to be 
in. In this example, we moved “Small Groups” to be the first item displayed under the parent 
page of “Connect” (with the exception for primary link variables set to true, as shown earlier). 

 
Once saved (by clicking on “Done”), you will see your menu re-organized in the way you 
ordered it. As shown below, “Small Groups” is now the second item for both mobile and 
desktop. If we were to turn off the primary link lava variables, then it would be displayed as the 
first child item instead. 
 
Desktop: 
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Mobile: 

 
The limit for the number of menu levels in this theme is three. This means you can have up to 
two dropdowns visually. Therefore, if you made changes to the number of levels in your page 
menu earlier to 1, you could change it again and set your desired menu levels back up to two or 
three.  
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Lastly, by default in core Rock, most of the external facing pages are set to show in the menu. 
This is because if you look at the individual page settings, and go to “Display Settings”, the value 
for the menu is set to “When Allowed”. This is nice to start with, but there are some pages you 
will want to turn off. See example below for the “Blog Details” page. 

 
It does not make sense to have this page visible from the menu because this page requires a 
specific blog item to function correctly. To turn this off, simply change the value from “When 
Allowed” to “Never”, and then click “Save”.  
 
Once you do this, you will see the menu for “Blog” is no longer a dropdown. Since “Blog” has 
only one child item (the details page), and we changed that menu display value to “Never”, this 
allows the page menu to show a direct link to the primary page instead.  
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With that in mind, we would recommend going through all your external facing pages (shown in 
the menu) and update their menu display settings accordingly. This way you have a clean public 
facing menu and can help your web audience from finding themselves into an empty page. 
 
As a reminder, if you find your menu being too long on desktop before it changes to 
mobile/tablet size, you can change that width value from within your Compass theme settings.  
 

 
Developer Bonus: If you need this menu to be in a content channel for other purposes, such as 

in-page anchor links, you can find the commented code within the file reference below and 
make it so: “/Themes/Compass/Assets/Lava/Site/SitewideNav.lava”  

 
 
 
 
 
  



Last updated: 02/29/24  9 Embers 
 

48 

TROUBLESHOOTING  
 
 
 
At this point, you have completed the installation of the Compass theme! If you come up with 
any template-related questions that are beyond the scope of this documentation file, please 
feel free to reach out to us at 9 Embers at https://9embers.com/.  
 
Thanks again for choosing us, and we are so excited to see what God does through you and 
your ministry with this theme. 
 


