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Introduction 
Planning Center Online (PCO) is a service that helps to manage teams of volunteer and 
especially the scheduling of those volunteers for specific weekend services. These volunteers are 
already in Rock so why should you have to re-enter all their information in PCO? What if your 
volunteers update their information in PCO, but not in Rock. The PCO Sync solves these problems 
for you, and it can sync any number of PCO accounts with Rock. 
Who Is Synced 
First, it's important to understand that the PCO Sync Plugin expects Rock to be the master list of 
people. If you add a new person directly to PCO, that person will not get added to Rock. New 
people should be added first to Rock and the sync will then add them to PCO. Now you 
obviously don't want to add everyone in Rock to PCO, so the sync will determine the list of 
people in one of a few ways. 

1. A new 'PCO Tags' person attribute can be updated on a person's profile to indicate which 
Tags they should have in PCO. In this case, anyone with one or more tags selected on this 
person attribute will get synced to PCO as a 'Scheduled Viewer' (unless they are granted 
further rights from #2 or #3). 

2. PCO tags can also be associated to a specific group in Rock. In this case, members of the 
group will have the security role of 'Scheduled Viewer' unless the group is configured to 
have a higher security level or they are granted further rights from #3. 

3. Groups can be configured to add people to PCO with a specific security level (Scheduled 
Viewer, Viewer, Scheduler, Editor, Administrator). 

When a person is first synced from Rock to PCO, the sync will look for a someone in PCO with 
the same first/nick name, last name, and email address. If it finds a match it will associate the 
Rock record with that existing PCO record. If it doesn't find a match, it will add a new person to 
PCO (and send that person the PCO welcome email). 
Note: You do have the option of running a one-time import of people from PCO into Rock (See the 
Importing PCO Records section below). 
What Data is Synced 
Once a record is linked between Rock and PCO, any updates to that person in either system will 
be synced back to the other system. The following is a list of the information that is synced 
whenever the value is changed: 
First Name (Given Name in PCO), Nick Name (First Name in PCO), Middle Name, Last Name, 
Gender, Birthdate, Anniversary, Home Address, Home Phone, Work Phone, Mobile Phone, Email, Tags, 
Photos, and the PCO Serving Permission Level. 
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Changes to these fields are synced both ways, unless it was the Photo and/or Permission Level. 
Photo and Permission Level are only synced one-way from Rock to PCO. If a photo is updated in 
PCO, or a person's permission level is changed in PCO, that information will not be synced back 
to Rock.  
NOTE: if the sync is configured to only query Planning Center for updated records, the Tags will 
also only sync one-way from Rock to PCO (See Setup section below) 
Permission Levels 
The permission level for a person is determined by looking at the synced groups in Rock that 
they are an active member of. The group with the highest permission level will determine the 
permission level to set when syncing them to PCO. The possible values in order of least to highest 
are: 
Scheduled Viewer, Viewer, Scheduler, Editor, Administrator. 
If a person belongs to a Tag group that does not have an explicit permission level defined, or 
they are being synced due to one or more tags selected on their person attribute, their security 
level will default to 'Scheduled Viewer'. 
By default, the PCO sync will never lower a person's permission level in PCO unless you enable 
the 'Allow Permission Downgrade' setting on the PCO Account Configuration (see Setup section 
below).  
If a person does not have any PCO tags configured and they no longer belong to a synced 
group in Rock (and the 'Allow Permission Downgrade' setting is enabled), the permission level in 
PCO will be set to 'Archived,' which essentially removes them from the Services application in 
PCO. 
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Setup 
Now that you have an idea of how the sync works, let's get it configured. You'll first need to 
configure your PCO account(s) in Rock, and decide which groups and or tags that you want Rock 
to sync. Before doing that though, you need to get two bits of information from PCO. 
Personal Access Tokens 
You'll need to create a Personal Access Token for your Planning Center Account. You do this from 
Planning Center Online. Visit https://api.planningcenteronline.com/oauth/applications to create 
a token. 

 
Under Personal Access Tokens, click the Create one now button.  
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When prompted for the description of this token, enter ‘Rock RMS Integration’.  
 

 
 
IMPORTANT: This plugin only uses Planning Center’s “People” and “Services” APIs. Make sure 
your token is configured for the correct version of these two API’s.  If the version of this plugin 
that you are installing/configuring is “Version 2.2.6” or earlier, you should use the following API 
versions: 
 
People: 2022-07-14 
Services: 2018-11-01 
 
If you are installing “Version 2.3.0” or later, the release notes of the plugin will indicate which 
version of the API that it is compatible with. 
 
You should now see an Application ID and Secret along with the API versions. You will need these 
values in the next step. 
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Configure PCO Account(s) in Rock 
Now that you have your Application ID and Secret from PCO, switch back to Rock and navigate 
to the new “Planning Center Online” page under Admin Tools > Installed Plugins. 

 
This page is used to configure the PCO account(s) that you will be syncing with, and the type of 
groups that should be allowed to sync with PCO. 
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Click the Add button at bottom of the Accounts grid, and enter your Application ID and Secret 
that you got from PCO when generating the new personal access token. 

 
Once you have entered the Application Id and Secret, select the Welcome Email from the list of 
email templates configured in your PCO account. Most of the time this will be the “Planning 
Center Welcome E-Mail”. Whatever email you select will be sent by PCO whenever a new 
person is added to PCO through the sync. 
Make sure to also enter a descriptive name for the account. We recommended checking the 
‘Allow Permission Downgrade’ option so that the permission level for people in PCO stays 
consistent with how you've configured their permissions in Rock. The sync will always increase a 
person’s permission level in PCO to the highest level they are allowed based on the group’s they 
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belong to in Rock. If the ‘Allow Permission Downgrade’ option is selected, the sync will also 
decrease permissions (or even archive people) based on the groups they belong to (or no longer 
belong to) in Rock. If you don’t want permissions to be decreased (or people archived), you can 
unselect the ‘Allow Permission Downgrade’ option. 
If you have multiple PCO accounts that you are going to sync with, follow the steps above for 
each account. 
Sync Job 
A new ‘PCO Sync’ job was added by the plugin to do the actual syncing of each person’s Rock 
and PCO demographic information. By default, it will run every two hours and will download 
every person’s record from Planning Center to determine if any information has changed. If 
you’d like to change how often it runs, you can configure the job from Admin Tools > System 
Settings > Jobs Administration and selecting the PCO Sync job. 
Updates Only 
In addition to changing the frequency of how often the job runs, you can also configure it to only 
query for records that were updated since the last time the job ran. This increases performance 
drastically, especially if you have a large number of people in Planning Center. The downside to 
using this option though is that any changes to tags made in Planning Center will not sync back to 
Rock because Planning Center does not consider that an update to the person record. To enable 
this option, edit the Job (Admin Tools > System Settings > Job Administration > PCO Sync), and 
set the Updates Only setting to “Yes”. 

 
Configure Tags and Groups for Syncing 
Now that you have set up the PCO account(s) and configured the sync job, you can start 
updating how people in Rock should be synced to PCO. 
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Update Tags 
On the Person Profile Extended Attributes tab, update the "Membership" section. Here you will 
see a new Person attribute that lists each of your PCO Tags and allows you to select the tags 
that a person should have in PCO. If you select any tag, that person will then be synced to PCO 
with that tag. You can select as many tags for a person as you would like. 

 
Configure Tag Groups 
If you would like one or more of the PCO tags to be synced based on membership in a Rock 
group rather than having to select that tag on each person's profile, you can configure that tag 
to sync with a group. The “Planning Center Online” page under Admin Tools > Installed Plugins 
includes a list of all your PCO tags.  
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Click on the tag that you'd like to sync to a group, and select that group that it should sync with. 

 
Any tag that is selected to sync with a group will appear with an asterisk on the person attribute.  
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This is to indicate that syncing for that tag is controlled by membership in a group and the 
selection of those tags will be updated by the sync to reflect whether they are an active member 
of the associated group or not (manually selecting or unselecting any of those tags will not make 
a difference since the selection will be updated by the sync). 
Configure Permission Groups 
By default, when syncing by tag, people are added to PCO as a 'Scheduled Viewer' which is the 
lowest permission level in PCO. If you'd like certain people to have elevated permissions, or 
would like to sync people who may not need a tag in PCO, you can configure groups to sync by 
permission level. You do this by setting the PCO Account and PCO permission level on a group. 
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Select the PCO account that you would like to sync members of this group to, and the permission 
level that you would like them to have in PCO (note: if a person in this group belongs to another 
group with a higher permission level, they will get synced to PCO with the higher level). 
For these fields to appear, the group's Group Type must be one of the Group Types added to 
the “Planning Center Online” page under Admin Tools > Installed Plugins. This contains a list of 
the Group Types that are configured to display these field (group attributes) as an option on 
their groups. The install automatically added the 'Serving Teams' group type, but you can add 
any other group types. 
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Deleting PCO Records 
When people are removed from groups that are syncing with PCO, the sync will automatically 
archive that person in PCO. Because of this, you typically do not need to worry about deleting 
records in PCO. However, if for some reason you would like to delete PCO records (i.e. a 
duplicate record got created), you do have that option. From the person list on the Account 
Detail page, you can click the delete button on any row, or even select multiple rows and click 
the “Delete Selected” button at the bottom of the grid. Doing this will delete the synced record in 
PCO (from both the Services and People apps). Keep in mind that if this person is still active in 
one of the synced groups in Rock, the next time the sync job runs, the person will be added back 
to PCO.  
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Monitoring Status 
You can check the status of which groups/people are currently being synced from the Account 
Detail page. Navigate to Admin Tools > Installed Plugins > Planning Center Online and select the 
account you’d like to view. 

 
The account details section lists all of the groups that are currently syncing to the selected PCO 
account and shows their permission level.  
The People list will show all the people in Rock that have been synced to PCO along with the 
PCO Id that was added and/or associated to the person and their current permission level in 
both Rock and PCO. If for some reason you need to change the PCO id that a person is being 
synced to, you can click their row in the list to display a dialog that allows you to set their PCO 
Id. 
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This dialog also displays the current demographic values that were saved by the sync job the 
last time it ran.  
The list of people is updated by the sync job each time It runs, but if new people have been 
added to Rock groups since the last time the job run, you can click the ‘Refresh List From Groups’ 
button to get them added to this list. 
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Importing PCO Records 
The PCO Plugin also allows you to import existing people from PCO into Rock. This is helpful if 
you already have people in PCO before you installed and configured the Sync. To import them, 
you will first need to create and configure at least one group for each of the permission levels 
that you want to import. Once you have configured the groups, navigate to the Admin Tools > 
Installed Plugins > Planning Center Online, select the account you’d like to import records from, 
and then click the “Configure Import Groups” link. 

 
This will display a dialog that lets you select the groups that PCO users should be imported to. 

 
Once you have selected a group for each permission level that you would like to import, click 
Save. Now that you have configured the groups, you will need to use the “PCO Import” job to 
import the people from Planning Center to Rock. 
PCO Import Job 
Now that you’ve configured the groups that people should be added to, you will need to run the 
PCO Import job for this account. From Admin Tools > System Settings > Jobs Administration click 
the PCO Import job to edit the settings for the job. Set the PCO Account setting to the correct 
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account and confirm the Default Connection status that should be used when the job adds people 
to Rock: 

 
Make sure NOT to turn on the “Active” flag. You don’t want this job to run automatically. After 
saving your settings, you can run the job manually by clicking the “play” button. 

 
The job will query PCO for all the people associated to the account. Then, for each person that 
has not already been configured to sync with PCO, will add them to the selected group based 
on their PCO permission level. For each person that it imports, it will try to find an existing Rock 
person with the same email, first name and last name. If it finds a matching person, it will sync to 
that person, otherwise it will add a new person to Rock. 
As the job runs and imports people, it will also update the status to indicate how many people 
have been imported. If the job stops running for some reason, it can be restarted and will 
continue where it left off. 
 
 


